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  1. Home
  2. NetBackup™ Troubleshooting Guide
  3. Troubleshooting procedures
  4. Troubleshooting security certificate revocation
  5. NetBackup job fails because of apparent network error
NetBackup™ Troubleshooting Guide

NetBackup job fails because of apparent network error

Symptom

A job may fail with network error 23, 25, 59, or perhaps other network error.

Cause

The host certificate of a NetBackup client or the media server that backs it up may be revoked. Also, the CRL on the client or the media server may be out-of-date, missing, or corrupt. Therefore, the client or the media server cannot determine that a host certificate is revoked. The job runs but communication fails and appears as a network error.

Resolution
  1. Determine if the client or the media server certificate was revoked.

    See Determining a NetBackup host's certificate state.

  2. Optionally, verify the cause by doing one of the following:

    • Log onto the revoked host and examine the vnetd proxy log file. Look for the message strings that contain the following:

      • PEER_HOST_PROTOCOL_ERROR

      • certificate revocation list

      • CRL and missing or corrupted

      See Viewing the vnetd proxy log files.

    • Use the NetBackup bptestbpcd command to see if a host certificate is revoked.

      See Determining a NetBackup host's certificate state.

  3. Resolve the issue:

    • If the CRL on a host is missing or corrupt, refresh the CRL on that host.

      How to refresh a host's CRL is documented in the NetBackup Security and Encryption Guide.

    • If an external CA-signed certificate is used, refer to the external certificate section.

      See Troubleshooting issues with external CA-signed certificate revocation.

    • If NetBackup CA-signed host certificate is revoked, resolve the security issue and then reissue the certificate.

      How to reissue a certificate is documented in the NetBackup Security and Encryption Guide.

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