Troubleshooting issues with Unstructured Data Instant Access
Problem:
Failed to create the instant access with error code 4001 for Unstructured Data Instant Access in AKS (Azure Kubernetes Service) or EKS (Amazon Elastic Kubernetes Service) environment.
Cause:
The MSDP engine on which the backup data is stored may not be in a healthy state.
Sample response message:
{
"errorCode": 4001,
"errorMessage": "Failed to create the instant access mount.",
"attributeErrors": {},
"fileUploadErrors": [],
"errorDetails": [
"Failed to provision the backup. /usr/openv/pdde/vpfs/bin/vpfs_
actions failed (1): Unable to getCatalog: ('Could not get
catalog of backup
(test-mssql1_1654780591): /usr/openv/pdde/vpfs/bin/cata2map failed
(255): ', {'statusInfo': {'msgId': 'Failed to
get catalog', 'parameters': [{'type':
'string', 'name': 'backupId', 'value':
'test-mssql1_1654780591'}]}})\n"
]
}
Resolution:
Check if the MSDP engines are healthy in your AKS or EKS environment. Alternatively, you can create a new backup and create Unstructured Data Instant Access again using its API interface.